Nacházíte se v kategorii: Linux

3. Únor, 2014
Zařazen do: Programování, Linux — Klerik @ 20:12

Pokud by někdo také provozoval Lighttpd a narazil na podobný problém jako já, tedy že se některé weby nespustili (v logu se objevovalo něco o socketu a neočekávaném konci souboru), tak je to řešitelné tímto příkazem: sysctl net.core.somaxconn=1024

Ale jinak všechno funguje super a rychle.

• • •
2. Únor, 2014
Zařazen do: Ostatní, Linux — Klerik @ 15:32

Tak dneska jsem na Lighttpd převedl kompletně všechno, co mi běželo na Apache. Konfigurace je mnohem snažší než je u Apache, takže se v tom už konečně vyznám, což se o Apache říct nedalo a hodně jsem si musel vypomáhat návody z internetu. Snad to tak vydrží :-)

• • •
1. Únor, 2014
Zařazen do: Linux — Klerik @ 15:10

Protože už mě fakt začalo štvát, jak složitě musím všechno řešit na Apache a jak nesmyslně se chová při různých chybách, tak jsem se rozhodl, že osonduji i trochu jiná řešení a kdysi jsem měl dobré zkušenosti s Lighttpd a po krátkém bádání jsem tento web krásně spustil a nebylo s tím takové sraní jako pod Apachem.
Samozřejmě ještě nemám vyhráno, protože na Apache jsem měl spousty webů i služeb, takže ještě bude nějakou dobu trvat, než na Lighttpd předělám všechno, ale věřím, že to půjde relativně snadno a na Apache budu moct zapomenout.
Pokud máte nějaké tipy pro nastavení Lighttpd nebo kdyby něco na tomhle webu nefungovalo, tak určitě dejte vědět.

• • •
1. Červen, 2013
Zařazen do: Linux, Ostatní — Klerik @ 14:52

OpenSuse 12.3 - tak svůj server, kde mimo jiné běží i tenhle blog, jsem upgradoval na nejnovější verzi OpenSuse. S upgradem jsem čekal, dokud i repozitář server_messaging nebude na tuto verzi připraven a to se stalo teprve nedávno. Upgrade proběhl bez problémů, až na jabber/xmpp server Prosody, viz dále ...

Jabberd - vzhledem k tomu, že Prosody je napsané v jazyce Lua, tak k sobě potřebuje poměrně dost "luáckých" knihoven, navíc v konkrétních verzích. Toto způsobilo, že už v předchozí verzi OpenSuse Prosody nefungovalo a musel jsem ručně instalovat starší verze knihoven. Toto se samozřejmě opakovalo i s přechodem na OpenSuse 12.3 a mně se do toho samozřejmě vůbec nechtělo. Vytáhl jsem tedy z nefunkčního Prosody jen seznam mých kontaktů a nainstaloval Jabberd2. Ten se kupodivu nastavuje podobně snadno jako Prosody, ale prostě funguje bez jakýchkoliv problémů a skoro hned.
K tomuto musím také dodat, že kdyby pánové, který se starají o repozitář server_messaging, vše pořádně otestovali, tak bylo všechno v pohodě. Nicméně mi stejně přijde, že Jabberd je lepší a perspektivnější než Prosody, takže ve finále jen dobře pro mě.

Firefox - už opravdu dlouho použivám Chrome/Chromium a na Firefox jsem jaksi zanevřel. Nicméně Chrome mi začalo nějak divně synchronizovat a navíc jsem se dočetl, že Google bude odstřihávat XMPP komunikaci na ostatní servery. Řekl jsem si, že dám Firefoxu zase šanci a okamžitě si mě získal. Především tím, že umožňuje pro synchronizaci použít vlastní server, což mi přijde prostě super. Když potom nebude synchronizace fungovat, tak to bude jen a jen můj problém, navíc nebudou data u někoho, komu do nich nic není. Co se týká používání nebo vzhledu, tak z mého subjektivního hlediska je to v zásadě to stejné co Chrome, akorát Firefox oplývá příjemnějším nastavením s více možnostmi.

• • •
13. Březen, 2013
Zařazen do: Linux, Život, Ostatní — Klerik @ 17:18

Jak asi mnozí z vás zaregistrovali, tak spousty stránek a služeb v České republice byly napadeny DOS nebo DDOS útoky z Ruska a podobných států. No a samozřejmě se snaží i na více frontách a nevyhnulo se to ani mému serveru :). Naštěstí byli neúspěšní :)).

Záznam:

Last failed login: Wed Mar 13 16:47:01 CET 2013 from server134.net14.intbildns.org on ssh:notty

There were 12 failed login attempts since the last successful login. 

 

• • •
9. Březen, 2013
Zařazen do: Linux, Život, Ostatní — Klerik @ 19:38

Dneska bylo hnusně, tak jsem si řekl, že nebudu čekat do úterý a udělám upgrade už dnes :).

Nejdřív jsem to zkusil na desktopu a tady to proběhlo prostě skvěle. Absolutně bez problémů.
Používal jsem to pár hodin a bylo to absolutně v pohodě. Navíc nové tmavé téma KDE se mi moc líbí. Mimochodem přešel jsem z MySQL na MariaDB a nepoznal jsem žádný rozdíl, takže toho se taky asi běžní uživatelé nemusí bát.

Pak jsem to zkusil na HTPC, kde to bylo taky v klidu, i když to na tom Atomu trvalo strašně dlouho :). 
No a tak jsem to pustil i na přítelčíném notebooku a i na domácím NAS a obojí už si také pohodově vrní na openSUSE 12.3 a je to prostě zase pecka :).

Pokud jste doposud váhali, tak neváhejte a upgradujte, je to v klidu :).

Díky všem ze SUSE za tak skvělou práci.

• • •
17. Únor, 2013
Zařazen do: Linux — Klerik @ 09:42

Odpočet do vydání :)Taky se těšíte tak, jak se těším já? :) Tohle bude první verze, kde budu využívat zřejmě hlavně distribuční repozitáře, tedy už žádná přídavná repa pro kernel:stable nebo pro KDE4.10. V téhle verzi už bude totiž KDE v dostatečné verzi, abych už po nových verzích netoužil a kernel bude ve verzi 3.7, což už je také verze, která mi bohatě stačí.

KDE4.10 považuji za nejlepší vydání KDE vůbec a tím myslím kompletně všechny verze, co kdy výšly, včetně těch tolik oblíbených trojkových verzí. Funguje to super, stabilita maximální, možnosti dostatečné a co víc si přát :).

No a kernel 3.7 mi stačí z toho důvodu, že už tam jsou opraveny všechny problémy se spotřebou a jsou tam přítomny už dost nové verze ovladačů pro akceleraci videa ve fullHD na Intel grafických kartách.

openSUSE je snad jediná distribuce, která mě zatím ničím nezklamala .... kéž jí to vydrží i dál :-).

• • •
4. Únor, 2013
Zařazen do: Linux — Klerik @ 11:46

Já se tak strašně těším na KDE 4.10. Za prvé by už konečně měl KMail být absolutně bez problémů (teď fungoval skvěle, ale po uspání počítače občas odmítl posílat maily) a také bychom se měli dočkat animovaných pozadí na ploše, což jsem vždycky chtěl, ale dosavadní řešení mi nikdy nevyhovovala. Takže už jen dva dny a je to doma :).

• • •
3. Listopad, 2012
Zařazen do: Linux, Život, Ostatní — Klerik @ 15:11

Jak jsem psal v předchozích dvou zápiscích, tak jsem se chystal nějakým způsobem upgradovat PC a měl jsem v merku poprvé ve svém životě něco od AMD. Místo původního plánu koupit nějakou grafárnu a pak nějaký procesor jsem se po dobré zkušenosti s ATI X550 (v zásadě by mi asi i stačila) rozhodl pro APU A10-5700, kde jsem očekával zkušenost podobnou. To byla ale blbost ...

Do teď jsem měl dvoujádrový procesor C2D E8200, který mi sice stačil, ale říkal jsem si, že čtyřjádro na výšších taktech, menším výrobním procesu a s novými instrukčními sadami bude určitě o něco lepší, než můj víc jak 4 roky starý procesor. Není to pravda. Už spouštění systému je pomalejší. Aplikace se spouštějí také mnohem déle a celkově byl počítač s A10-5700 pomalejší.

Korunou všeho byla integrovaná grafika. OpenSource ovladače měly menší výkon než na původní ATI X550 a nebyly úplně stabilní, tu a tam nějaký ten zásek, občas při změně rozlišení ve hře totálně spadla Xka nebo i celý systém. Experimentoval jsem i s nejnovějším kernelem a nejnovějšími ovladači, více méně se stejným výsledkem, pokrok jsem nezaznamenal. Toto jsem ale byl ochoten odpustit, protože podpora pro Trinity není v OS ovladačích dlouho a navíc jsem předpokládal, že to vyřeší binární blob přímo od AMD. Opět obrovská chyba.

Binární ovladače od AMD se do OpenSuse sice nainstalují absolutně snadno, fungují okamžitě a výkon podávají relativně dobrý. Bohužel tyto binární ovladače nejsou kvalitou absolutně srovnatelné s nVidia ovladači. Stabilita opět pokulhávala a i když mi to nikdy neshodilo ani Xka, tak některé hry prostě vytuhly a musely být ukončeny "násilně". Navíc třeba UT2004 se spouštěl s hrozným blikáním, které ustalo až po nějaké chvíli (prý problém s vsync, nevím) a některá flashová videa v prohlížeči, která jsem si zvětšil na fullscreen se pak projevovala jen úplně modrou obrazovkou, kterou, ale když jsem vypnul, tak to v prohlížeči běželo dál bezproblémově.

Na můj vkus to bylo až moc věcí, které mi na tomhle řešení vadily. Takže jsem všechno vrátil (díky nákupům na internetu) a s pokorou jsem se také vrtátil ke svému starému, ale božskému procesoru, kterému jsem jako parťáka pořídil SSD OCZ Vertex 3 60GB a k tomu MSI N650Ti-1GD5/OC, ke kterému jsem navíc dostal kupón na Assassin's Creed III, které dostanu, hned jak vyjde (už jsem to registroval). Mimochodem, je pravda, že SSD disk urychlí počítač daleko víc, než nový procesor nebo kterýkoliv jiný hardware.

Závěrem musím říct, že jsem celkové zklamaný z celého AMD. Procesorový výkon mizerný a kvalita grafických ovladačů ještě mizernější. Pro běžné užívaní je to pro mě nepoužitelné. Hlavně by měli zapracovat pořádně na OS driverech.

Nicméně až to zase za pár let s AMD zkusím, třeba budou už open source ovladače grafických karet dokonalé a proceserový výkon budou zajišťovat ARM jádra :)) a vše bude v pohodě.

• • •
26. Říjen, 2012
Zařazen do: Linux — Klerik @ 15:44

Tak jsem prodal svoji grafickou kartu nVidia Gefroce GTX 560Ti a rozhodl jsem, že koupím nějakou kartu od AMD (viz. můj předchozí zápisek). Vzhledem k tomu, že pořád ještě nemám jasno, jestli mi stačí Radeon 7770 a nebo vezmu radši 7850, tak jsem si řekl, že si nechám nějaký čas na rozmyšlenou a půjčím si nějakou kartu v práci. V práci mají samozřejmě samý low end a vždycky jsme tu měli jen karty nVdidia. Jaké bylo moje překvapení, když jsme při prohrabavání skladu našli ATI X55O s čipem R300 :).

Mimochodem při hledání jsme tentokrát nenašli ani žádnou nVidia a jedinou kartou do PCI-E 16x byla právě X550, už to vypadalo, že se budu muset spokojit s Matroxem do nějakého PCI-E 1x nebo co to bylo :).

Teď už ale k samotné kartě ATI X550, která na sobě nese slušných 256 mega paměti. Protože problematiku grafických karet v linuxu sleduji, tak vím, že tenhle čip nepodporuje ani legacy driver od AMD a musím proto rovnou sáhnout po open source ovladači, se kterým bych ale neměl mít žádné problémy.

Po startu počítače OpenSuse naběhlo rovnou do fullHD rozlišení, ale nějak se mi přestala v KDE vlnit okna, tak jsem koukl, jestli funguje direct rendering a samozřejmě nic. Takže mrk do logu Xorg a tam mi to řeklo jediný error ohledně špatného načtení nVidia GLX. Uvědomil jsem si, že jsem zapomněl odinstalovat nVidia ovladače, což jsem učinil a v závislostech se vyměnily nějaké knihovny GL za jiné GL (nechce se mi to vypisovat :)). Po restartu iXek už se okénka vlnila a direct rendering taky šel. glxgears podali "slušných" 60 fps :).

Sláva open source ovladačům, takhle jednoduše bych to chtěl vždycky. Byla by fakt nádhera, kdybych linux nainstaloval i s ovladači grafické karty a měl vystaráno - bohužel jak všichni víme, situace je taková, jaká je.

Vzhledem k tomu, že karta je už opravdu stará, tak jsem neočekával, že bych si na tom i cokoliv zahrál, natož ve Wine. Nicméně jsem zkusil spustit Broken Sword 3 a ono ejhle, jede to absolutně stejně, jako to jelo s GF560Ti, akorát mi přišlo rychlejší přepínání rozlišení. Jde tedy zkoušet dál a pouštím Heart of Darkness, které mám už rozehrané asi 10 let a ono to taky jede absolutně bez problémů :). Když už jsem u těch her a u toho wine, tak si spustím ještě Quadrax III a ono se mi to poprvé spustilo v normálním fullscreenu, s nVidií se mi to vždycky ořezávalo na nějaké nativní rozlišení té hry a tak jsem měl většinu obrazovky černou a v ní malé okno s Qadraxem, takže jsem to hrával radši v okně. Zatím samé plusové body pro opensource driver.

Dále jsem zkusil spustit World of Goo, to se nespustilo. Pak Gish, ten se spustil a i když to bylo trochu trhané, tak to bylo hratelné. Pak jsem zkusil UT2004 a kupodivu když člověk oseká detajly, tak to jede (i když né úplně plynule). Staré hry si tedy absolutně v pohodě zahraju a jsem v klidu.

Pak jsem zkoušel videa. Akceleraci videa to zdá se nevede, ale zjistil jsem, že můj procesor C2D E8200 si s FullHD mkv poradí absolutně v klidu, takže mě to netrápilo. Nicměně jsem zpozoroval, že při spuštěných více oknech se mi začalo trhat vlnění oken a občas se při přesunu okna pod záhlavím objeví taková divná modrá čára, která ale hned mizí. Nicméně čím měně oken, tím je to lepší :).

Můj celkový dojem z open source driverů pro grafické karty ATI/AMD je ale rozhodně dobrý. Funguje to hned, žádné přidávání repozitářů a instalování binárních blobů. Nic se nemusí nastavovat a jde vidět, že i Wine se líp pracuje s takovými ovladači. Jen mě to utrvdilo v tom, že je nutné začít karty AMD podporovat, aby se vývoj hýbal co nejrychleji.

Někdy příští týden koupím buď MSI R7770 a nebo MSI R7850 a ty zatím fungují jen přes binární blob. Jsem zvědavý a určitě o tom sem zase napíšu. Víkend si ale užiju ještě na X550 :)).

• • •

Strany:
[1] [_] [3] [4] [5] [6] [7]